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1. Introduction 
 
SPSS (Statistical Package for Social Science) is a comprehensive package for data analysis developed 
by IBM Corporation. The software facilitates its users to collect, handle, clean and present the data” in 
the forms of tables, graphs, descriptive statistics, reports, trend lines, etc. SPSS can read almost any 
type of data e.g. numeric, alphanumeric, binary, date, currency and so on. The data in SPSS can be 
viewed and edited from dropdown menus and dialogue boxes. 
 
In this manual, the example of dataset for NSSO round “Schedule 25.2: Participation and Expenditure 
in Education, 64th Round" is used. This survey was conducted during the period of July 2007 to June 
2008. 
 
2. Opening a Data File in SPSS 
 
To open a dataset or file, select the following functions from the dropdown menus: 
File >Open >Data 
 
Mainly, two types of “views” are available in SPSS to view a data file, i.e. "Data View" and "Variable 
View". 
 

 
Fig. 1: Data View 

 
Fig. 1 is the screenshot of "Data View" in SPSS, where rows represent the numbers of households, and 
columns represent the variables for which information has been collected from the households.  
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The "Variable View" is shown in Fig. 2, where each row represents the number of variable and each 
column represent the nature of variable.  
 

  
Fig. 2: Variable View 

 
In Fig. 2, the first column provides "name" of variable which is generally written in short  form using 
underscores. Second column provides "type" of variable, i.e. whether it is numeric, alphanumeric, 
string, date, etc. 
 
To check, click at "String" option. On clicking at “String”, Option Box shown in Fig. 3 will appear. Select 
the appropriate type in the available option box and click on "OK". 
 

 
Fig. 3: Option Box to Define Type of Variable 
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The third column provides expected length of a given variable; whereas the fourth column provides 
number of decimal places for a given variable. The fifth column provides "Label", where users can 
provide full name of the variable whose short form is given in Column one. 
 
The sixth column in Fig. 2, provides "Values" assigned to a variable, e.g. whether the information 
provided in the dataset is for rural and urban population, here 1 denotes rural and 2 denotes urban 
population.  
 
On clicking at the "Values" button, the Option Box that appears is shown in Fig. 4, type "1" in the 
"Value" box and name of variable in the "Label" box; Click at "OK". 
 

 
Fig. 4: Option Box for Value Labels 

 
Seventh column in Fig. 2 provides information on "Missing" values in the dataset. In case, there are 
missing values in the dataset, one can assign values to them which will appear in the dataset. For 
assigning value to missing values, click at "missing", a new Option Box will appear as shown in Fig. 5. 
Select "Discrete missing values" from the Option Box and write the value you want to assign, click at 
"OK". For example, 999 is assigned for the missing values here. 
 

 
Fig. 5: Assigning Value to Missing Values 
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3. Importing Text Data 
 
Generally, most of the social sciences data are in text format providing information on each 
household, individual and firm, etc. In this section, the functions to import text data in SPSS file is 
described. 
 
To import text data, select: File > Read Text Data from the dropdown menus in SPSS. The first (of six 
step) “Text Import Wizard” shown in Fig. 6.1will appear to facilitate import of text data. 
 

 
Fig. 6.1: Text Import Wizard (Step-1) 

 
This wizard seeks information on pre-defined format of text file. In this case, since the file is not pre-
defined, leave it unfilled and click at “Next” button. The second Text Import Wizard will appear as 
shown in Fig. 6.2.  
 

 
Fig. 6.2: Text Import Wizard (Step 2) 
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Select appropriate format from which variables are be imported viz. delimited and fixed width. In 
most of files, variables are arranged in fixed width, and in this case also, we have the fixed width data. 

So, here  option is selected. Click at the 
appropriate option. Choose "Next" button to proceed as shown in Fig. 6.2. The third Text Import 
Wizard will appear as displayed in Fig. 6.3. 
 

 
Fig. 6.3: Text Import Wizard (Step 3) 

 
In the third Text Import Wizard reproduced in Fig. 6.3, each line represent a case. Select“1" in the first 
box as shown in the above in Fig. 6.3. Similarly, here the data begins with first line, so "1" is selected 
again in the second box. Next, choose how many case do you want to import? Since, all the cases are 
to be imported, select "all the cases" option. Click at "Next" button to get the fourth Text Import 
Wizard as shown in Fig. 6.4. 
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Fig. 6.4: Text Import Wizard (Step 4) 

 
In order to extract variables from the dataset, the data is to broken in columns appropriately. In this 
example, variables are extracted by clicking on 3rd column, 8th column and so on which are 
represented in black lines as shown in Fig. 6.4. These breaks are created in accordance with the layout 
file provided by NSSO. After breaking the variables in appropriate columns, click at "Next" to get the 
fifth of six Text Import Wizard as shown in Fig. 6.5. 
 

 
Fig. 6.5: Text Import Wizard (Step 5) 
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In fifth Text Import Wizard(Fig. 6.5), name and nature to each variable is to be assigned. In this 
example, the first variable is selected and assigned the name "CENTER_ROUND_SHIFT" and "numeric" 
as its nature. Likewise, assign names and nature to each variables. Click at "Next" button to get to the 
sixth and last Text Import Wizard as shown in Fig.6.6. 
 

 
Fig. 6.6: Text Import Wizard (Step 6) 

 
In the six and last step, select "Yes" or No" options in the check boxes as shown in Fig. 6.6. Click at the 
"Finish" button to imported the data in the SPSS format  as shown in Fig. 1.Cross check the number of 
observations in the SPSS file with the information provided in the supporting documents. In NSSO 
data, the supporting documents refers to the "README" file.   
 
4. Value Labels 
 
The “Value Labels” function is available under the "View” function. This function is to be used to 
display the ordinal variable (i.e. rural=1 and urban=2), either in values or in labels in the window. To 
use value labels function, select the following options from the dropdown menu: 

Select, View > Value labels 
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As shown in Fig. 7, values of the variable are displayed as 1 in the "Sector" column.  
 

 
Fig. 7: Display of Value Labels of Variable 

In order to change the value labels of variable, click at Value Labels. On clicking at “Value Label”, 
screen shot of output that is displayed is shown in Fig. 8.The label of the variable is shown as “Rural” 
in the Sector variable. 
 

 
Fig. 8: Display of Changed Value Labels of Variable 
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5. Reports  
 
The reports menu of SPSS provides basic information or summary of various variables in the dataset. 
The basic information includes valid cases, missing values, mean, median and mode, etc. To generate 
reports, select the following options  from the dropdown menus: 
Analyze > Reports > Codebook or OLAP Cues or Case Summaries 
 
In this example, "Codebook" is selected first. On selection of “Codebook”, Option Box that is 
displayed, is shown in Fig.9. 
 

 
Fig. 9: Codebook 

 
In the example given in Fig. 9, "consumption expenditure" is selected from the variable list in order to 
view information about it. Click at "OK" button, as  a result Table 1 given below is displayed. 
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 Value 
Standard Attributes Position 49 

Label Consumption 
expenditure during last 
30 days on Free 
collections(Rs.) 

Type Numeric 
Format F4 
Measurement Scale 
Role Input 

N Valid 240077 
Missing 205883 

Central Tendency and Dispersion Mean 248.32 
Standard Deviation 229.858 
Percentile 25 100.00 
Percentile 50 200.00 
Percentile 75 300.00 

Table 1: Display of Information Related to a Variable 
 

Table 1 above provides information on position, label, type, format, measurement, role, valid, 
missing, mean, standard deviation, and percentile of consumption expenditure, etc. 
 
To summarize the cases available in the variable, select the options given below from the dropdown 
menus:  
Analyze > Reports > Case Summarize 
 

 
Fig. 10: Summarize Cases of a Variable 

 
Select required "Variables" and "Grouping Variables" from left-end option window to right-hand 
selection box using arrow buttons. In this example, "Consumption expenditure" in variables and 
"Sector" in grouping variable is selected. After selecting both the variables, click at "OK" button. 
Resultant output is shown in Table 2 and Table 3. 
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Cases 
Included Excluded Total 
N Percent N Percent N Percent 

Consumption expenditure
during last 30 days on Total 
(Rs.)  * Sector 

445944 100.0% 16 0.0% 445960 100.0% 

Table 2.1: Case Summarize of a Variable 
 

Sector 

Consumption 
expenditure during 
last 30 days on Total 
(Rs.) 

Rural 290155 
Urban 155789 
Total 445944 

Table 2.2: Case Summarize of a Variable 
 
Table 2.1 and Table 2.2 provides number of cases involved in the consumption expenditure variable. 
Here, almost 100 percent cases are valid, involving 290155 rural and 155789 urban cases.  
 
6. Descriptive Statistics 
 
Descriptive statistics in SPSS is used to find out certain basic statistics of variables, e.g. frequencies of 
various variables, their summary, relationship between two variables, etc.  
 
6.1 Frequency Calculation 
 
To calculate the frequencies of rural and urban household in sample survey, select the following 
options from dropdown menu:  
Analyze > Descriptive Statistics > Frequencies 
 
On selection of the above mentioned menu items, "Frequencies" calculation box will appear as shown 
in Fig. 11. Select "sector" from variable(s)and checkbox for "Display frequency tables". Click at "OK". 
Table 4 will be displayed with results for frequencies calculation of specified variable(s). 
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Fig. 11: Frequencies Calculation 

 

 Frequency Percent Valid Percent 
Cumulative 
Percent 

Valid Rural 
63318 63.0 63.0 63.0 

Urban 37263 37.0 37.0 100.0 
Total 100581 100.0 100.0  

Table 3: Display of Frequencies Calculation Result 
 

Table 3 reveals that are 63,318 rural and 37,263 urban households selected for the survey. Result in 
also shown in terms of percentage, where 63 percent of households are rural and 37 percent are 
urban.  

Further, click at  option in the "Frequencies" calculation box, to calculate several other 
statistics as shown in the Option Box for "Frequency : Statistics" given in Fig. 12. 
 
You can calculate the percentile values , e.g. deciles, quartiles, etc which is shown in the upper left 
column of the Option Box in Fig. 12. You can also calculate the measures of central tendency, like 
mean, median, mode, etc. using “Statistics” function. Similarly, the measures of dispersion (like 
standard deviation, variance, and range) and distribution (skewness, kurtosis) can also be calculated 
with selection of appropriate options given in the left-side and right-side panel in the lower half of the 
Option Box, respectively Fig. 12).  
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Fig. 12: Frequencies: Statistics calculation 

 
For calculating mean, standard deviation, quartiles and skewness of the total consumption of 
households; check the appropriate boxes, e.g. Quartiles, Std. Deviation, Mean, and Skewness, as 
shown in the Fig. 12. Click at "Continue". Table 4 will be displayed as output of these selections. 
 

N Valid 100578 
Missing 3

Mean 3798.02 
Std. Deviation 2931.657 
Skewness 3.884 
Std. Error of Skewness .008
Percentiles 25 2000.00 

50 3000.00 
75 4700.00

Table 4: Calculation of Different Statistics 
 
The Table 4 displays the mean, standard deviation, skewness and quartile class of total consumption 
expenditure of households. While the above two rows namely, "valid" and "missing" reveals that 
there are three missing values in the dataset and the remaining 100578 values are valid. 
 
6.2 Comparing Two Variables (Cross Tabulation) 
 
Relationship between two variables can be found using "Cross Tabulation" option available in SPSS.  
Select the following options from the dropdown menus for cross tabulation:  
Analyze > Descriptive Statistics >Crosstabs 
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On selection of the above mentioned options from dropdown menu, the Option Box given in Fig. 13 
will appear. In the example given here, relationship between "Social Group" of population and "Land 
Possessed” by them is calculated. Select "social group" variable in the row(s) and "land possessed" in 
the column(s) from the Option Box given in Fig. 13. 
 

 
Fig. 13: Cross Tabulation 

 
Click on "Cells" option given in the top right-hand panel (Fig. 13), to calculate the row-wise and 
column wise percentage. In this example, row wise percentage is calculated and observed counts, 
which is shown in the Fig. 14.  
 
Further, check the "Counts" option and select "Percentages" option, to calculate the cross tabulation 
of two variables. In this example, cross tabulation of two variables, i.e. Social Group * Land Possessed 
code is calculated as shown in Fig. 14.  
 

 
Fig. 14: Crosstabs: Cell Display 
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The resultant output has been displayed in Table 5, where "land possessed" variable is divided into 
two parts viz. 3.01 to 4.00 acres and greater than 8.00 acres. And, "social group" is classified into 
schedule tribe, schedule caste, OBCs and Others. This output reveals that most of the households 
have3.01 to 4.00 acres of land. 
 

 

Land Possessed code 

Total 
3.01 -  4.00 
……. 

greater than
8.00 

Social Group scheduled tribe Count 144 1 145 
% within Social Group 99.3% 0.7% 100.0% 

scheduled caste Count 86 0 86 
% within Social Group 100.0% 0.0% 100.0% 

other  backward class Count 126 3 129
% within Social Group 97.7% 2.3% 100.0% 

Others Count 53 3 56 
% within Social Group 94.6% 5.4% 100.0%

Total Count 409 7 416 
% within Social Group 98.3% 1.7% 100.0%

Table 5: Display of Result for Cross Tabulation between Variables 
 
Further, one can also cross tab these two variables with one or more categorical variables e.g. for 
rural and urban sector, by using the layer option in "Crosstabs" as shown in Fig. 15. Select "Sector" 
variable in the "Layer" option and click at "OK". This layer option is not confined to only one 
categorical variable. As such, you can select more than one layer options for cross tabulation.  
 

 
Fig. 15: Crosstabs Calculation Window 



SPSS 22: User Guide
 

16  

 

Resultant cross tabulation results are given in Table 6, where cross tabulation is calculated between 
Social Group, Land Possessed code and Sector. 
 

Sector 

Land Possessed code 

Total  
3.01 -  4.00 
……. 

greater than 
8.00 

Rural Social Group scheduled tribe 22492 17436343 167831 17626666 
scheduled caste 971 34602163 123130 34726264 
other  backward class 22311 67290135 1417870 68730316
others 11003 36765957 1404156 38181116 

Total 56777 156094598 3112987 159264362 
Urban Social Group scheduled tribe 3547 1946002 3070 1952619 

scheduled caste 5471 9471957 8848 9486276 
other  backward class 13913 22913112 70716 22997741 
others 20811 28619421 169369 28809601

Total 43742 62950492 252003 63246237 
Total Social Group scheduled tribe 26039 19382345 170901 19579285 

scheduled caste 6442 44074120 131978 44212540
other  backward class 36224 90203247 1488586 91728057 
others 31814 65385378 1573525 66990717 

Total 100519 219045090 3364990 222510599 
Table 6: Crosstabs Calculation for Social Group, Land Possessed code and Sector 

 
Further, as shown in Crosstabs Calculation Window (Fig. 16), various statistics between the two 

variables can also be calculated, e.g. chi-square, correlations, etc. For that, click at option in 
the "Crosstab" window and select the required statistics to be calculated from the Option Box, then 
click at "Continue" to get the results.  
 

 
Fig. 16: Crosstabs Statistics Calculation 
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7. Sort Cases 
 
The "Sort Cases" data in SPPS is used to sort the data in ascending or descending order. This task can 
be perform by selecting following options from the dropdown menus: 
Data > Sort Cases... Select Ascending / Select Descending 
 
Select "ascending order" to sort your data in ascending order, else select "descending order". In the 
example given here,  "State codes" selected for sorting in "ascending order" using option 
as shown in Fig. 17.  
 

 
Fig. 17: Sort Cases 

 
Table 7 below displays data arranged in ascending order by state codes. 
 

 
Table 7: Display of Result in Sorting Cases Order 
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8. Select Cases 
 
The "Select Cases" option in SPSS works as the filter function. Select options given below from the 
dropdown menu to filter the data:  
Data > Select Cases 
 
On selection of above-mentioned options, Option Box that is displayed is given in Fig. 18.Select the 
appropriate variable, e.g. "Sector" to bring it to the "Use filter variable" box. Click at "OK" as shown in 
Fig. 18. The data is filtered out and is displayed as shown in Table 8. 
 

 
Fig. 18: Selecting and Filtering Cases 

 

 
Table 8: Filtering Cases on Sector 
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9. Split Data 
 
Split data command is very useful to compare the information of a variable in terms of categorical 
variables. In the example given here, "consumption expenditure "is compared for rural and urban 
sectors.  
 
Select the following options from dropdown menu to do so: 
Data > Split File... 
 
On selection of options given above, the Option Box that appears is shown below in Fig. 19. Select 

and take "Sector" variable in the Selection Box. Click at "OK". Select the option 

that appears at the bottom right-end of the Option Box. 
  

 
Fig. 19: Option Box for Split File 

 
The output file is displayed as shown in Table 9. Here, descriptive statistics of the variable 
"Consumption Expenditure" is calculated and the result is separated for rural and urban sectors.  
 

Sector N Min. Max. Sum Mean 
Std. 
Deviation 

Rural Consumption expenditure during
last 30 days on Total (Rs.) 159260258100 53500 4686340759552942.571865.105 

Valid N (list wise) 159260258   
Urban Consumption expenditure during

last 30 days on Total (Rs.) 63246236 1 80000 3333801374245271.153916.585 

Valid N (list wise) 63246236   
    

Table 9: Split File based on Sector 
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10. Custom Tables 
 
Custom table function in SPSS is useful to prepare a wide range of tables, e.g. two way tables, three 
way tables, four way tables, etc. 
 
10.1 Two Way Tables 
 
Two way tables calculate the relationship between two variables. For example, total consumption 
expenditure of households hailing from different religious groups can be calculated by selecting 
options given below from the dropdown menus: 
Analyze > Tables > Custom Tables. 
 
On selection of options given above, Option Box given in Fig.  20 will appear. 
 

 
Fig. 20: Calculation of Custom Tables 

 
Select "Consumption Expenditure" variable from the variables list to Rows and "Religion" to Columns 
as shown in Fig. 20. Select any statistics, like sum, count, mean, percentage, std. deviation and so on, 

by clicking at from the  menu. Select the desired statistics and click at
 as shown in Fig.  21. Click at "OK". 
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Fig. 21: Calculation of Two-way Custom Tables 

 
Table 10 will appear as output with "religion" shown in "columns" and "consumption" in  "row". 
 

 

Religion 

Hinduism Islam ChristianitySikhism Jainism Buddhism 
Zoroastriani
sm 

No 
Respons
e 

Sum Sum Sum Sum Sum Sum Sum Sum 
Consumpti
on  655313872

428 
923456833
31 

206803310
76 

17627589
33 

236932330
82 

37880321
18 

426028250
2 

1700199
08 

Table 10: Two-way Custom Table: Religion Vs Consumption Expenditure 
 
10.2 Three Way Tables 
 
Three way tables provide information on two variables with one categorical variable. In continuation 
of previous example, we can calculate "total expenditure of households" for different religion with a 
categorical variable such as rural and urban, i.e. total expenditure of different religious groups in rural 
and urban sector. To do so, select the options given below from the dropdown menus:  
Analyze > Tables > Custom Tables 
 
On selection of above-mentioned options, screenshot of Option Box that is displayed is given in Fig. 
22. Select "Consumption Expenditure" from rows and "Religion" from columns. Select "Sector" 
variable in rows (before consumption) for calculating consumption expenditure by rural and urban 
population and choose the required statistics. Click at "OK" as shown in Fig. 22. The resultant output 
is given in  Table 11. 
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Fig. 22: Calculation of Three-way Custom Tables 

 
Likewise, you may calculate four ways, five ways tables by selecting categorical variables in rows and 
columns.  
 

 

Region 

1 2 3 4 5 6 

Sum Sum Sum Sum Sum Sum 
Sector Rural Consumption 

expenditure during
last 30 days on
Purchase (Rs.) 

1046692991041015750517186152552374436782466440 39967622178 4314904812

Urban Consumption 
expenditure during
last 30 days on
Purchase (Rs.) 12386721854574612338570 6496981924429540417949 26766574845 2854422799

Table 11: Three-way Custom Table 
 

Table 11 given above displays total consumption of different religion belonging to rural and urban 
areas. 
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11. Compute Variable 
 
New variables can be calculated by adding, subtracting, multiplying (etc.) two or more numerical 
variables using "compute variable" option. In this example,  sum of expenditure of two variables, 
namely, gift and free collection is being calculated. Select the following options from the dropdown 
menus: 
Transform > Compute Variable. 
 
On selection of above mentioned options, an Option Box will appear on the screen wherein write the 
name of new variable in the "Target Variables" box and select the two variables in "Numeric 
Expression". In this example, "Gift_free" is selected in "Target Variables" box, "gifts and loans" and 
"free collection" variables are selected in "Numeric Expression". To add values of these two variables, 
"addition" function is required as shown in Fig. 23. Click at "OK" button. As a result, "Gift_free", i.e.  a 
new variable will be computed in the dataset and result will be displayed as shown in Table 12. 
Likewise additional statistical values can be computed by combining two, three or more numbers of 
variables. 
 

 
Fig. 23: Computing Additional Variable 
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Table 12: Computed Variable- "gift_free" 

 

Further, the option given at the bottom can also be used for 
calculating the new variable involving categorical variable. Continuing with our example, to add "gifts 
and loans" and "free collection "only for "rural" sector, select "If". The Option Box given in Fig. 24 will 

appear. Click on at and select "Sector" variable. Use "=" sign from 
the symbol box given in Fig. 24, select type 1 for rural sector, and click at "Continue" as shown in Fig. 
24. A new variable will be created only for rural areas. Similarly, this function can be performed for 
urban areas by selecting type 2 in the “include if case satisfies condition” function. 
 

 
Fig. 24: Compute Variable: If Cases 
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Table 13: Computed Variable: If Cases 

 
12. Recoding of Data 
 
The "recoding of data" option is used when the two or more variables are to be combined. In the 
example given above, there is a variable called, "distance from home to primary school", with value 
varying from 1 to 5  kilometres . For combining values 1 and 2 into a single value e.g. 10, options to be 
selected are as follows:  
Transform > Recode Into different Variables. 
 
On selection of options given above, Option Box that is displayed is given in Fig. 25.1 with header 
"Recode Into different Variables".  
 

 
Fig. 25.1: Recoding of Different Variables 
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Select "distance variable" from list of variables into Selection Box, type the name you want to assign 

to the new variable. Click at . A new Option Box will appear as shown in Fig. 25.2.  
 

 
Fig.25.2:Recoding of Different Variables: Old and New Values 

 
Select the "range" and write"1"and"2" in the boxes under "Range" of Old Value menu, and select the 
"Value" under the New Value menu and click at "Add" button. Select all other values, e.g. "20" and 
click  at "Continue". As a result, a new variable with combined values will be created in the dataset as 
shown in Table 14. 
 

 
Table 14: Combined Values for Recoding of Different Variables 
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13. Rank Cases 
 
The "rank cases" option can be used to distribute the whole dataset into various equal parts i.e. from 
1 to 100 or 10 to 100 etc. Here, we will calculate "decile" class of "total consumption expenditure" 
variable i.e. distributing the consumption expenditure into 10 equal parts. The options for calculation 
of "decile" class is as follows: 
Transform > Rank Cases.  
 
A new Option Box is displayed as shown in Fig. 26. Select the "consumption expenditure" variable in 

the "variable(s)" box and Click on  as shown in Fig. 26. 
 

 
Fig. 26: Calculation of Rank Cases 

 
The new Option Box that is displayed is given in Fig. 26.1. Check the "Ntiles" box and type 10 into it. 
Click on "Continue", a new variable with the name of  will be created and a new Option 
Box(Fig. 26.3) prompting users to assign value to the “Tie”, i.e. low, high or low. 
 

 
Fig. 26.1: Calculation of Rank Cases: Types 
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In this example, "mean" value is assigned to the “Tie” as shown in Fig. 26.3. Click at “Mean" and 
"Continue". Resultantly, Table 15 is displayed that shows newly created variable based on "decile" 
values. 

 
Fig. 26.3: Calculation of Rank Cases: Ties 

 

 
Table 15: Calculation of Rank Cases 

 
To distribute the dataset into 4 equal parts i.e. quartile, click  at "Ntiles" and type"4" in the box, click 
at "Continue" and "OK" as shown in Fig. 26.4. A new variable with the quartiles will be created in the 
dataset as similar to Table 15. 
 

 
Fig. 26.4: Calculation of Rank Cases: Types 
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14. Weight Cases 
 
The "weight cases" command in SPSS is very useful for taking an estimate of the data from sample 
data. The NSSO data set provide the "Multiplier" which is to be used while estimating the data. In 
SPSS, cases are weighted by a variable with the help of following function: 
Data > Weight Cases. 
 
On selection of above mentioned options, the Option Box is that is displayed is shown in Fig. 27. 
 

 
Fig. 27: Calculation of Weight Cases 

 
Select the "Weight cases by" and select  the "weight to attach variable" in the “Frequency Variable" 

box and click at "OK". The  result will appear in the bottom right of the window. 
 
15. Aggregate Data 
 
The "aggregate data" command of SPSS convert the data files from the disaggregated level to 
aggregated level. For example, the dataset that we are dealing with provides information on 
consumption expenditure for each household for different states of India. To create a dataset on 
state-wise consumption expenditure information, select the following options from the dropdown 
menus: 
Data > Aggregate   
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On selection of above mentioned options, the Option Window that is displayed is given in Fig. 28. 
 

 
Fig. 28: Calculation of Aggregate Data 

 
From the Option Box, select state variable in  and desired variable to be aggregated 
in the . In this example, "total consumption expenditure" is selected. For 

selecting desired statistics, click at below the . The new Option 
Box  that appear is shown in Fig. 28.1. 
 

 
Fig. 28.1: Calculation of Aggregate Data: Aggregate Function 
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Select desired statistics from the Option Box 28.1. In this example, "Sum" is selected. Click at 
"Continue". Now go back to the "Aggregate Data "Option Box and from the "Save" menu given in the 
Middle of Option Box, select  as shown in Fig. 
28.2 and type the name of new data set in the “dataset name:” In this example, we have typed the 
"New data" in the box. Click at ;a new data set will be created with the assigned name as 
shown in Table 16.  
 

 
Fig. 28.2: Calculation of Aggregate Data: Aggregate Function (Step 2) 

 

 
Table 16: Aggregated Data 

 
16. Merging Data 
 
“Merging Data” is used to merge two variables from two different files. In other words, “Merging 
Data” is used to add a variable in the dataset. Examples of use of “Merging Data” option is given 
below: 



SPSS 22: User Guide
 

32  

 

16.1 Adding New Variables 
 
Data > Merge Files > Add Variables. 
 
On selection of above-mentioned functions from the dropdown menus, “Add Variable Wizard "given 
Fig. 29 is displayed. Select a file to be merged and click  at "Continue". However, before using this 
option both the files must be sorted by the identifier variable. In this example, it is HHID (Household 
ID).  
 

 
Fig. 29: Adding New Variables 

 
The next stage “Add Variable Wizard” that appears is shown in Fig. 29.1. The common variable here is 

"HHID" which is to be selected in after selecting the . Select 

the , and click at "OK". As a result, a new variable will 
be added in the dataset as Var00001 as shown in Table 17. 
 

 
Fig. 29.1: Adding Variables to Dataset 
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Table 17: Added Variables 

 
16.1.1 Adding Variables When Numbers of Cases in Two Files are Uneven 
 
While merging two datasets, it is necessary that the number of cases in two files must be the same, If 
the number of cases are not equal, there will be greater number of missing values and that would be 
difficult for any calculations. To handle it, the dataset having higher number of cases need to be 
restructured.  
 
16.1.1.1  Restructuring Data 
 
In the example taken here, there are two files, one provides information on households where 
numbers of cases are lesser than the other file which provides information on individuals. Now to 
merge these two files, restructuring of data is required. Follow the steps given below for restructuring 
of files: 
Data > Restructure...  
 
The Restructuring Wizard (Step 1) that appears is shown in Fig. 30.1. Select the second option, i.e. 

for transposing the information of individuals from cases to 
variables, so that the number of cases in this file becomes equal to the number of cases in other file.  
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Fig. 30.1: Restructure Data Wizard (Step 1) 

 
After selecting "restructure selected cases into variables", Click at "Next". The second step of the 
Wizard that appears is shown in Fig. 30.2. 
 

 
Fig. 30.2: Restructure Data Wizard (Step 2) 
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Now, select the "HHID" (i.e. the same values for the cases) to the "Index variables", and the variables 
which need to be restructured should be selected to the "Identifier variables" and Click "Next" as 
shown in Fig. 30.2. 
 
Second step of Wizard that appears is shown in Fig. 30.3. Select the 

and again click on "Next". 
 

 
Fig. 30.3: Restructure Data Wizard (Step 3) 

 
The forth step wizard that appears is shown in Fig. 30.4. Click on "Next" button.  
 

 
Fig. 30.4: Restructure Data Wizard (Step 4) 
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Click at "Next" to get the final and fifth step of Wizard as shown in Fig. 30.5. Click at "Finish" button in 
that window. The data will be restructured in terms of number of households. Now, two datasets can 
be merged. 
 

 
Fig. 30.5: Restructure Data Wizard (Final Step) 

 
16.2 Adding New Cases 
 
Similar to "adding variable", you can add new cases in the dataset using menu option from the 
dropdown menu given below: 
Data > Merge File > Add Cases. 
 
On selection of the options given above, the Option Box that appears is shown in Fig. 31. Select "An 
external SPSS Statistics data file" and click at "Browse" button. 
 

 
Fig. 31: Adding New Cases: Browse and Selecting File 
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Now, select the file from where the cases are to be added, and click "OK".  Subsequently, the Option 
Box that appears is shown in Fig. 32.  
 

 
Fig. 32: Adding New Cases: Renaming or Deleting Unpaired Variables 

 
Fig. 32 shows the unpaired variables which are not available in one dataset, are shown in the 
unpaired variables box. You can handle these unpaired variables either through renaming or deleting 
them from the file, then click "OK". The new cases will be added to the file as shown in Table 18. 
 

 
Table 18: Result Display of Adding New Cases: Renaming or Deleting Unpaired Variables 

 
17. Output Files 
 
The "output" files are the files, where the final calculation appears. For example, calculating the 
frequencies of households from rural and urban sector, shown in Fig. 33. The tables in output files can 
also be edited, by double clicking it. The table will be activated. Now, select options from the 
dropdown menus to edit the table. In this example, "Table Looks" is used by selecting following 
option from dropdown menu: 
Format > Table Looks  
 
Select "classic" look of the table, as shown in Table 19. There are many other options that can use, 
e.g. sorting the tables, transposing the tables, cell formats, etc.  
 



SPSS 22: User Guide
 

38  

 

 
Fig. 33: Creation of Output File 

 

 
Table 19: TableLooks of Output File 

 
Further, click at "cell properties", the following wizard will appear as shown in Fig. 34. You can change 
the font and background, format value, alignment and margins. The change of font and background is 
shown in Fig. 34. 
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Fig. 34: Cell Properties- Font and Background 

 
Click at "format value", wizard that appears is shown in Fig. 35where the edition in terms of value 
format can be edited. Similarly, alignment and margins can also be defined. 
 

 
Fig. 35: Cell Properties- Format Value 
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17.1 Run Script 
 
You may also use the "run script" option from the Toolbars to do the same calculation for other files. 
On clicking at "run script", the wizard that opens is shown in Fig. 36. 
 

 
Fig. 36: Run Script 

 
Select any file from your system and click on "Run". The same calculation will be done for different 
file. 
 
18. Syntax 
 
Syntax in SPSS is the third window, where you can run the earlier commands and the results will be 
produced on a single click. To open a new syntax file, go to: 
File > New > Syntax. 
 
The following Syntax Editor will appear as shown in Fig. 37. 
 

 
Fig. 37: Syntax Editor 
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Now, copy the commands from the output file, and paste it in the syntax file. The name of file can 
also be changed. Click at "Run" from the toolbars after selecting required command (s) The same 
calculation will be done for another file. 
 
19. Graphs  
 
In SPSS, one can draw a wide range of graphs, e.g. histogram, bar, line, area, scatter, plot, etc. To 
prepare graph, select the "Graphs" from the dropdown menu. The Option Box for "Chart Builder "that 
appears is as shown in Fig. 38. Select desired type of graph from the list which are given in the 
"Gallery". "Bar diagram" is selected in this example. The resultant bar diagram is shown in Fig. 38, 
where "Sector" has been taken on the X-axis and "Expenditure" on Y-axis.  
 

 
Fig. 38: Chart Builder Window and Creation of Graph 
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To plot average expenditure of households in rural and urban areas,  select "Mean" from the 
"Statistics" menu in the "Element Properties" as shown in Fig. 39. 
 

 
Fig. 39: Chart Builder- Element Properties 

 
On taking the steps mentioned above, the graph produced as output is shown in Fig. 40.  
 

 
Fig. 40: Bar Chart 

---------------------------------------------------------------------- 
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